import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.*_Page)\\d+$(?!\\r?\\n\\1\\d+$)";
final String string = "A_File1_Page1\n"
+ "A_File1_Page2\n\n"
+ "A_File2_Page1\n"
+ "A_File2_Page2\n"
+ "A_File2_Page3\n\n"
+ "B_File1_Page1\n"
+ "B_File1_Page2\n"
+ "B_File1_Page3\n\n"
+ "B_File2_Page1\n"
+ "B_File2_Page2\n"
+ "B_File2_Page3\n"
+ "B_File2_Page4\n\n"
+ "C_File1_Page1\n"
+ "C_File1_Page2\n"
+ "C_File1_Page3\n"
+ "C_File1_Page4\n"
+ "C_File1_Page5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}