package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:https?|ftp):\/\/?)?([^:/\s.]+\.[^:/\s]|localhost)(:\d+)?((?:\/\w+)*\/)?([\w\-.]+[^#?\s]+)?([^#]*)?(#[\w-]*)?$`)
var str = `https://localhost:8000/dir/1/2/search.html?k1=v1&k2=v2&k3#hash
google.ca`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}