const regex = /^((?:https?|ftp):\/\/?)?([^:/\s.]+\.[^:/\s]|localhost)(:\d+)?((?:\/\w+)*\/)?([\w\-.]+[^#?\s]+)?([^#]*)?(#[\w-]*)?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:https?|ftp):\\\/\\\/?)?([^:\/\\s.]+\\.[^:\/\\s]|localhost)(:\\d+)?((?:\\\/\\w+)*\\\/)?([\\w\\-.]+[^#?\\s]+)?([^#]*)?(#[\\w-]*)?$', 'mg')
const str = `https://localhost:8000/dir/1/2/search.html?k1=v1&k2=v2&k3#hash
google.ca`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}