package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<p>([^:]+)\s*:\s*([\d.]+\s+\w+)<\/p>`)
var str = `<p>Packet size: 20 cm</p><p>Weight: 1.2 kg</p><p>Allows you to collect your hair easily.</p><p><br />Holds your hair, does not come out.</p><p>No more fussing with rubber buckles.</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}