re = /<p>([^:]+)\s*:\s*([\d.]+\s+\w+)<\/p>/
str = '<p>Packet size: 20 cm</p><p>Weight: 1.2 kg</p><p>Allows you to collect your hair easily.</p><p><br />Holds your hair, does not come out.</p><p>No more fussing with rubber buckles.</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end