$re = '/^[a-zA-Z0-9](?!.* $)[a-zA-Z0-9 ]{0,254}$/m';
$str = 'a
a bc
abc xyz foo bar
abc xyz
foo bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);