import re
regex = re.compile(r"^[a-zA-Z0-9](?!.* $)[a-zA-Z0-9 ]{0,254}$", flags=re.MULTILINE)
test_str = ("a\n"
"a bc\n"
"abc xyz foo bar\n"
"abc xyz \n"
" foo bar")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")