re = /^[a-zA-Z0-9](?!.* $)[a-zA-Z0-9 ]{0,254}$/m
str = 'a
a bc
abc xyz foo bar
abc xyz
foo bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end