#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(https?:\/\/)?+(www)?([^:\/]+\.)?mysite\.[a-zA-Z]{1,3}"
Local $sString = "dsad" & @CRLF & _
"https://www.google.ee" & @CRLF & _
"http://www.mysite.com" & @CRLF & _
"www.mysite.ee" & @CRLF & _
"https://mysite.au" & @CRLF & _
"mysite.io" & @CRLF & _
"dsa kdadas das das www.google.com fsafsa fasf as" & @CRLF & _
"dsadasdas http://google.com" & @CRLF & _
"dasd" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")