re = /(https?:\/\/)?+(www)?([^:\/]+\.)?mysite\.[a-zA-Z]{1,3}/m
str = 'dsad
https://www.google.ee
http://www.mysite.com
www.mysite.ee
https://mysite.au
mysite.io
dsa kdadas das das www.google.com fsafsa fasf as
dsadasdas http://google.com
dasd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end