// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https?:\/\/)?+(www)?([^:\/]+\.)?mysite\.[a-zA-Z]{1,3}").unwrap();
let string = "dsad
https://www.google.ee
http://www.mysite.com
www.mysite.ee
https://mysite.au
mysite.io
dsa kdadas das das www.google.com fsafsa fasf as
dsadasdas http://google.com
dasd
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}