use strict;
my $str = '<div id="olpProductDetails" class="a-fixed-left-grid-col a-col-right" style="padding-left:0%;float:left;">
<h1 class="a-size-large a-spacing-none" role="main"> <div class="a-section a-spacing-none olpSubHeadingSection"> <span class="a-size-base a-color-secondary"> </span> </div> Keds Women\'s Chillax Washed Laceless Slip-On Sneaker, Taupe, 8 M US
</h1>
<div id="olpProductByline" class="a-section a-spacing-mini">
by Keds
</div>
<div class="a-section a-spacing-small">
';
my $regex = qr/<div\sid=\"olpProductDetails[\s\S]*?<h1[\s\S]*?<div[\s\S]*?<span[\s\S]*?>[\s\S]*?\s*<\/span>\s*<\/div>\s*([\s\S]*?)[\s]+<\/h1>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}