// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<div\sid=\"olpProductDetails[\s\S]*?<h1[\s\S]*?<div[\s\S]*?<span[\s\S]*?>[\s\S]*?\s*<\/span>\s*<\/div>\s*([\s\S]*?)[\s]+<\/h1>"#).unwrap();
let string = "<div id=\"olpProductDetails\" class=\"a-fixed-left-grid-col a-col-right\" style=\"padding-left:0%;float:left;\">
<h1 class=\"a-size-large a-spacing-none\" role=\"main\"> <div class=\"a-section a-spacing-none olpSubHeadingSection\"> <span class=\"a-size-base a-color-secondary\"> </span> </div> Keds Women's Chillax Washed Laceless Slip-On Sneaker, Taupe, 8 M US
</h1>
<div id=\"olpProductByline\" class=\"a-section a-spacing-mini\">
by Keds
</div>
<div class=\"a-section a-spacing-small\">
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}