import re
regex = re.compile(r"<div\sid=\"olpProductDetails[\s\S]*?<h1[\s\S]*?<div[\s\S]*?<span[\s\S]*?>[\s\S]*?\s*<\/span>\s*<\/div>\s*([\s\S]*?)[\s]+<\/h1>", flags=re.MULTILINE)
test_str = ("<div id=\"olpProductDetails\" class=\"a-fixed-left-grid-col a-col-right\" style=\"padding-left:0%;float:left;\">\n\n"
" <h1 class=\"a-size-large a-spacing-none\" role=\"main\"> <div class=\"a-section a-spacing-none olpSubHeadingSection\"> <span class=\"a-size-base a-color-secondary\"> </span> </div> Keds Women's Chillax Washed Laceless Slip-On Sneaker, Taupe, 8 M US\n"
" </h1>\n"
" <div id=\"olpProductByline\" class=\"a-section a-spacing-mini\">\n"
" \n\n\n\n\n\n"
"by Keds\n\n"
" </div>\n\n"
" <div class=\"a-section a-spacing-small\">\n"
" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")