use strict;
my $str = 'esd hedf L:1,2,3 *sm
CONF: FEDEX 12345 L: 12(2),2(9),32 *SM
ESD: 12/12/92 L:
tRacking\' my data L: 1,2,3(4)
tracking
ConF\'\'\' something \'\' L: 6
esd test 24(7)';
my $regex = qr/^
(CONF|ESD|TRACKING)
(?:
\h*[:;'\h]\h*
(.*?)
(?:
\h*L\h*[:;'\h]\h*
(
(?:\d+(?:\(\d+\))?)
(?:\h*,\h*\d+(?:\(\d+\))?)*
)
(?:
\h*(\*[.a-z]+)
)?
)?
)?
\h*
$/imxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}