// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?imx)^
(CONF|ESD|TRACKING)
(?:
\h*[:;'\h]\h*
(.*?)
(?:
\h*L\h*[:;'\h]\h*
(
(?:\d+(?:\(\d+\))?)
(?:\h*,\h*\d+(?:\(\d+\))?)*
)
(?:
\h*(\*[.a-z]+)
)?
)?
)?
\h*
$").unwrap();
let string = "esd hedf L:1,2,3 *sm
CONF: FEDEX 12345 L: 12(2),2(9),32 *SM
ESD: 12/12/92 L:
tRacking' my data L: 1,2,3(4)
tracking
ConF''' something '' L: 6
esd test 24(7)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}