import Foundation
let pattern = #"""
^
(CONF|ESD|TRACKING)
(?:
\h*[:;'\h]\h*
(.*?)
(?:
\h*L\h*[:;'\h]\h*
(
(?:\d+(?:\(\d+\))?)
(?:\h*,\h*\d+(?:\(\d+\))?)*
)
(?:
\h*(\*[.a-z]+)
)?
)?
)?
\h*
$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
esd hedf L:1,2,3 *sm
CONF: FEDEX 12345 L: 12(2),2(9),32 *SM
ESD: 12/12/92 L:
tRacking' my data L: 1,2,3(4)
tracking
ConF''' something '' L: 6
esd test 24(7)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)