#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([a-z\d\#]+)-([\d]+)-([\d]+)"
Local $sString = "color-price-count" & @CRLF & _
"#dsd-sdsd-sdsd-sds" & @CRLF & _
"red-569-12-12" & @CRLF & _
"#ff3322-233-44-jj"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")