// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-z\d\#]+)-([\d]+)-([\d]+)").unwrap();
let string = "color-price-count
#dsd-sdsd-sdsd-sds
red-569-12-12
#ff3322-233-44-jj";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}