$re = '/([a-z\d\#]+)-([\d]+)-([\d]+)/';
$str = 'color-price-count
#dsd-sdsd-sdsd-sds
red-569-12-12
#ff3322-233-44-jj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);