#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/.*\/.*(?<!.htm)$"
Local $sString = "/blabla/test" & @CRLF & _
"/blabla/" & @CRLF & _
"/blabla/blabla.ht" & @CRLF & _
"/blabla/blabla.html" & @CRLF & _
"" & @CRLF & _
"/bla/blabla.htm" & @CRLF & _
"blabla/" & @CRLF & _
"/blabla" & @CRLF & _
"blabla"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")