using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/.*\/.*(?<!.htm)$";
string input = @"/blabla/test
/blabla/
/blabla/blabla.ht
/blabla/blabla.html
/bla/blabla.htm
blabla/
/blabla
blabla";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}