import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*(\\W|^)foo(\\W|$))(?=.*(\\W|^)bar(\\W|$))(?!.*(\\W|^)baz(\\W|$)).*$";
final String string = ".foo# bar text\n"
+ ".foo# bar\n"
+ ".foo# fo bar\n"
+ ".foo# bar baz\n"
+ ".foo# baz bar\n"
+ "baz bar .foo#\n"
+ "bar .foo# boo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}