const regex = /^(?=.*(\W|^)foo(\W|$))(?=.*(\W|^)bar(\W|$))(?!.*(\W|^)baz(\W|$)).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*(\\W|^)foo(\\W|$))(?=.*(\\W|^)bar(\\W|$))(?!.*(\\W|^)baz(\\W|$)).*$', 'gm')
const str = `.foo# bar text
.foo# bar
.foo# fo bar
.foo# bar baz
.foo# baz bar
baz bar .foo#
bar .foo# boo`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}