$re = '/^(?=.*(\W|^)foo(\W|$))(?=.*(\W|^)bar(\W|$))(?!.*(\W|^)baz(\W|$)).*$/m';
$str = '.foo# bar text
.foo# bar
.foo# fo bar
.foo# bar baz
.foo# baz bar
baz bar .foo#
bar .foo# boo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);