$re = '/^(:[^:\n]+:[^:\n]+)*?:43:([^:]+)/m';
$str = ':101:abc:12:43:43:101.4:4:bus
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);