// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(:[^:\n]+:[^:\n]+)*?:43:([^:]+)").unwrap();
let string = ":101:abc:12:43:43:101.4:4:bus
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}