const regex = new RegExp('^([^.]*\\.[^.]*)\\.', 'gm')
const str = `Hello. world. Hello!`;
const subst = `\1_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);