use strict;
my $str = 'Hello. world. Hello!';
my $regex = qr/^([^.]*\.[^.]*)\./mp;
my $subst = '\\1_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";