import re
regex = re.compile(r"^([^.]*\.[^.]*)\.", flags=re.MULTILINE)
test_str = "Hello. world. Hello!"
subst = "\\1_"
result = regex.sub(subst, test_str)
if result:
print(result)