using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(?=((?<=\d\s))*)(\d+\s)*)(абв)(?=(\s\d+)*)";
string input = @"123 абв 123 абв абв 123 абв";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}