$re = '/(?(?=((?<=\d\s))*)(\d+\s)*)(абв)(?=(\s\d+)*)/';
$str = '123 абв 123 абв абв 123 абв';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);