#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(CAR.*)AIRPLANE"
Local $sString = "CAR" & @CRLF & _
"one a. , z." & @CRLF & _
"two b." & @CRLF & _
"three c." & @CRLF & _
"AIRPLANE" & @CRLF & _
"one a. , z." & @CRLF & _
"two b." & @CRLF & _
"three c." & @CRLF & _
"BOAT" & @CRLF & _
"one a. , z." & @CRLF & _
"two b."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")