import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(CAR.*)AIRPLANE";
final String string = "CAR\n"
+ "one a. , z.\n"
+ "two b.\n"
+ "three c.\n"
+ "AIRPLANE\n"
+ "one a. , z.\n"
+ "two b.\n"
+ "three c.\n"
+ "BOAT\n"
+ "one a. , z.\n"
+ "two b.";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}