$re = '/(CAR.*)AIRPLANE/s';
$str = 'CAR
one a. , z.
two b.
three c.
AIRPLANE
one a. , z.
two b.
three c.
BOAT
one a. , z.
two b.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);