const regex = /(?<=Python\s).*?(?=\s+words)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Python\\s).*?(?=\\s+words)', 'gs')
const str = `This is a test to see if I can get Python to print out all the words in between Python and words`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}