re = /(?<=Python\s).*?(?=\s+words)/
str = 'This is a test to see if I can get Python to print out all the words in between Python and words'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end