const regex = /\[.*\] \[INFO\] \[paperless\.auth\] Login failed for user `.*` from IP `<HOST>`/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[.*\\] \\[INFO\\] \\[paperless\\.auth\\] Login failed for user `.*` from IP `<HOST>`', 'gm')
const str = `[2024-05-19 22:25:53,852] [INFO] [paperless.auth] Login failed for user \`sasas\` from private IP \`192.168.60.1\`.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}