re = /\[.*\] \[INFO\] \[paperless\.auth\] Login failed for user `.*` from IP `<HOST>`/m
str = '[2024-05-19 22:25:53,852] [INFO] [paperless.auth] Login failed for user `sasas` from private IP `192.168.60.1`.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end