#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Saint\h+(\w+)\h+eats(?|\h+(\w+)\h+of|())\h+those\h+(\w+)"
Local $sString = "Saint John eats less of those apples." & @CRLF & _
"Saint Paul eats more of those berries." & @CRLF & _
"Saint Luke eats those oranges."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")