import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Saint\\h+(\\w+)\\h+eats(?|\\h+(\\w+)\\h+of|())\\h+those\\h+(\\w+)";
final String string = "Saint John eats less of those apples.\n"
+ "Saint Paul eats more of those berries.\n"
+ "Saint Luke eats those oranges.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}