$re = '/^Saint\h+(\w+)\h+eats(?|\h+(\w+)\h+of|())\h+those\h+(\w+)/m';
$str = 'Saint John eats less of those apples.
Saint Paul eats more of those berries.
Saint Luke eats those oranges.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);