package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bhttps?:\/\/[^/]*\bspotify\.com\/playlist\/([^\s?]+)`)
var str = `https://open.spotify.com/playlist/1GXN1gZMuTlW5LjpTNJF2q
https://open.spotify.com/playlist/1GXN1gZMuTlW5LjpTNJF2q?si=d3fa4293e26049f8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}