re = /\bhttps?:\/\/[^\/]*\bspotify\.com\/playlist\/([^\s?]+)/m
str = 'https://open.spotify.com/playlist/1GXN1gZMuTlW5LjpTNJF2q
https://open.spotify.com/playlist/1GXN1gZMuTlW5LjpTNJF2q?si=d3fa4293e26049f8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end