const regex = /\bhttps?:\/\/[^/]*\bspotify\.com\/playlist\/([^\s?]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bhttps?:\\\/\\\/[^\/]*\\bspotify\\.com\\\/playlist\\\/([^\\s?]+)', 'gm')
const str = `https://open.spotify.com/playlist/1GXN1gZMuTlW5LjpTNJF2q
https://open.spotify.com/playlist/1GXN1gZMuTlW5LjpTNJF2q?si=d3fa4293e26049f8`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}