#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/\/([\w.-]+).*\/"
Local $sString = "<iframe id="donato-if" src="https://site.org/includes/donate.php?as_page=1&platform=wb&referer=http%3A//site2.org/web/20130129160928/http%3A//site3.ru/2005/10/29/prostranstvo-intellekta/"" & @CRLF & _
"" & @CRLF & _
"<a href="https://site4.ru/lalala/http://site5.ru/" rel="external nofollow" class="url">lalala</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")