package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/\/([\w.-]+).*\/`)
var str = `<iframe id="donato-if" src="https://site.org/includes/donate.php?as_page=1&platform=wb&referer=http%3A//site2.org/web/20130129160928/http%3A//site3.ru/2005/10/29/prostranstvo-intellekta/"
<a href="https://site4.ru/lalala/http://site5.ru/" rel="external nofollow" class="url">lalala</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}