import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\/([\\w.-]+).*\\/";
final String string = "<iframe id=\"donato-if\" src=\"https://site.org/includes/donate.php?as_page=1&platform=wb&referer=http%3A//site2.org/web/20130129160928/http%3A//site3.ru/2005/10/29/prostranstvo-intellekta/\"\n\n"
+ "<a href=\"https://site4.ru/lalala/http://site5.ru/\" rel=\"external nofollow\" class=\"url\">lalala</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}