using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)(?|^(\d+):()()|\G^()([-+]?\d+)(?![:\d])[ \t]+(.*)|\G^()()()[ \t]*$\R*)\R?";
string substitution = @"$1\t$2\t$3\r\n";
string input = @"6:
1 my 1st log
-2 my 2nd log
7:
-3 my 3rd log
4 my 4th log
-5 my 5th log
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}