use strict;
my $str = '6:
1 my 1st log
-2 my 2nd log
7:
-3 my 3rd log
4 my 4th log
-5 my 5th log
';
my $regex = qr/(?m)(?|^(\d+):()()|\G^()([-+]?\d+)(?![:\d])[ \t]+(.*)|\G^()()()[ \t]*$\R*)\R?/p;
my $subst = '$1\\t$2\\t$3\\r\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";